[uclibc-ng-devel] dlclose() issue

Waldemar Brodkorb wbx at uclibc-ng.org
Wed Apr 11 06:39:53 CEST 2018


Hi,

I still having issues with dlclose().
Can anybody help me with this issue?

This is a long standing bug and still not solved.
Recently I reverted commit 952bb00f0b2eb576b0bf48c4f87018429a42e28d
in commit 5bdc2b4dee516c8e4d7ba9f5d26c9bf31418b52f, because
some Gentoo people reported issues with preparing stage1/stage2
images with this patch applied. 

The problem which was fixed by accident with this commit is
segfaults in dlclose when running apache2 or php -m.

But the munmap() calls where just wrong.

Then I thought I found a real fix for the dlclose() segfaults in
the old uClibc bugtracker
https://bugs.busybox.net/show_bug.cgi?id=6158
I tested and pushed commit bf4c2d242f587700e3eb2ffd5721ddaf3cdbc7e5.

But this change introduces a regression when running the uClibc-ng
testsuite. When running testscope test, the test case fails, as
the function registered via atexit(), is no longer available after
dlclose() is executed.

Why the dlclose() function is so extremely complex in uClibc and
glibc? Musl seems to do nothing in dlclose() :/

Any help is really appreciated.

best regards
 Waldemar


More information about the devel mailing list