[uclibc-ng-devel] [uclibc-ng] Fail to build [libc/inet/if_index.os] when building uClibc-ng 1.0.12 with 2.6.22.19 kernel headers

Waldemar Brodkorb wbx at uclibc-ng.org
Wed Feb 10 20:28:48 CET 2016


Hi Alex,
Alex Potapenko wrote,

> Hi Waldemar,
> 
> 2016-02-09 21:46 GMT+02:00 Waldemar Brodkorb <wbx at uclibc-ng.org>:
> > I rather would like to avoid supporting such very old kernels.
> > The oldest supported kernel is 2.6.32.70.
> > Could you try using this for the toolchain?
> > What runtime problems occur, when you use 2.6.32.70 for toolchain
> > and then run the code on 2.6.22.19?
> >
> > I verified that 2.6.32.70 works with uClibc-ng for mipsel toolchain.
> 
> I haven't tried 2.6.32.70 -- the issues I had happened with 2.6.36.4
> toolchain on 2.6.22.19 system. One issue I'm absolutely sure is due to
> older kernel is this one:
> https://sourceware.org/ml/gdb-prs/2015-q4/msg00337.html
> I later found out that ARMv5 gdb has the same issue if run on 2.6.12,
> but works OK on my test 2.6.36.4 machine (2.6.36.4 toolchain as well).
> And there're others that are very hard to debug, e.g., I found out
> that php crashes when configuring owncloud8 if pdo_mysql module is
> loaded (this doesn't happen on other test targets where systems run
> kernels not older than toolchains').
> 
> I also see that Entware-ng project is using 2.6.22.19 kernel with
> uClibc-ng 1.0.9. They're also using quite a lot of uClibc-ng patches:
> https://github.com/Entware-ng/Entware-ng/tree/master/toolchain/uClibc/patches
> The first two are safe to ignore (they're just hardcoding '/opt' into
> prefix definitions, I don't need that -- I configure
> UCLIBC_RUNTIME_PREFIX as '/opt' instead; well, I'd need some parts of
> the patches to get working utils on the target system, but I don't
> package them as of now), but I wonder if some of the others would make
> uClibc-ng compile with 2.6.22.19 headers? It'd be good if you could
> take a look.

Most of the patches in Entware-ng are already in uClibc-ng 1.0.12.
I see no related patch to your issues.

Can you please update your uClibc-ng to 1.0.12?
 
> P.S. I'll try 2.6.32.70 headers as soon as I can

Thx.

I will check the gdb issue on my MIPSel system.
If your php crashed with some dso, I have this for you:
https://lists.uclibc.org/pipermail/uclibc/2013-November/048061.html

best regards
 Waldemar
 


More information about the devel mailing list