[uclibc-ng-devel] memmove() is failing on MIPS CPU

Lance Fredrickson lancethepants at gmail.com
Tue Apr 26 16:23:42 CEST 2016


I've also experienced the same issues described by Rene.  Up until now 
I've been applying the patches that entware-ng/optware-ng use which 
revert the mipsel changes between 1.0.9 and 1.0.10.

Without Rene's patch, or reverting those mipsel commits, Rene's test.c 
fails to run, and experiences same error's he experiences.
With his patch it is working as expected.

Note: with or without patching, the static "test" binary I make works 
with qemu on x64_86 machine.  It's only when I run it on the actual 
mipsel hardware that it fails. So testing with qemu for whatever reason 
is not an indication in this case of how it will work on the actual 
hardware.

kernel 2.6.22.19
binutils 2.25.1
gcc 5.3.0
mips32 soft-float

I'm working with routers like entware-ng/optware-ng, so am also stuck on 
the same kernel they are.  I know entware-ng is using cross-tools-ng for 
their toolchain.  I am using buildroot for mine.

thanks,
     Lance
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.uclibc-ng.org/pipermail/devel/attachments/20160426/c96a6134/attachment.html>


More information about the devel mailing list